Unable to manually update

Hi Guys,

For some reason, my tablets get updated automatically but my phone does not. I have to manually update my phone. Now I am trying to install the latest and all I get is “Cannot be installed”. If you click on the problem button, there are a few things to try like deleting cache and such. Did them all and still no soap. Got plenty of room so that’s not an issue. Until I get this update, I will get the version mismatch error. Arrrggghh. Any good ideas my good people?

What kind of phone do you have? If it’s on Android, i know the Play store has an option in settings or on the game page to turn on auto updates. If it’s on iphone, i have no idea. Not an apple user.

This would be more of an Apple or Google thing you need to look into, maybe try contacting the relevant store supports. I found this update took a long time for me to download and install, longer than usual; make sure you have a solid internet connection when downloading as if your internet cuts in and out or fluctuates it may cause errors or not all the update to download successfully. Rather than try fix any errors if it downloaded incomplete, it starts the download from scratch.

Thanks Gir and Gale for your support. Gale, it sounds like my connection may be weak. It downloads, but fails to install. It then tries to restart the download. Man, does this blow or what? I guess if I try to uninstall and reinstall, I would lose all of my data. Uh, is that right?

If you have your account backed up/connected to google or Facebook you should be able to recover your account.

And you can’t just download without wifi if connection sucks? Or because of data charges

The fact that you are saying it fails to install sounds to me exactly what I theorised in my above message, your connection must be having problems downloading the update and not downloading it correctly or fully so the install fails and you revert back to trying to download from scratch again. My suggestion would be to use 4G or find another wifi to download the update on, if you have any other device see if that has trouble downloading the game and update first. If you delete the game and then it has an error and can’t download the game at all then you can’t play. So make sure your account is backed up with Facebook, that is the only reliable way to ensure your account is safe, try another device and try another connection, if all else fails try and delete and reinstall, I doubt this will solve the problem but stranger things have happened.

Delete app then reinstall

If it is Android device, this update it downloaded in 2 pieces ( 95% + 5% ). I don’t know if it had happened for previous ones. Make sure that both pieces gets installed.

Thank you all for your support. I shall look into making a backup, cause it still suckin so hard. Gale, my 2 tablets update automatically. Gir, you asked what kind of wack phone I am using, it a TCL. Uhhh, free phone for oldies.

OK, finally back on. My phone asked me to update when I started the game. Of course I said yes and tried to start the process. Did the same as B4, could not install and started the download again. So, i got a lil pissed and decided to go all out. When into App settings and deleted cache and data on Google, The Playstore, Downloads, and Drive. restarted my phone. Stared the app and again started the update process. This time it worked. All is right in the world, again.
Again, thanks to you all. You’re a good bunch.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.