Hook Shot a bit less hooky

Is it just me or are others noticing that Keel’s Hook Shot doesn’t seem to root anything anymore? I regularly see her hook explode over the enemy heads and then they just keep running.

I just tested this out and found the same issue of hook shot not rooting for 6 seconds. Probably should’ve tested it out in a duel but went Pvp with some aoe attackers and keel and finally got to a match where there was enough time to charge a root on an Alvarez. 1-2 seconds later he was rolling away from a purifier flame. No Francoise or any Debuff on other team.

Now it worked… thats weird. Is there a miss chance on the root?

I’ve had and still have that issue. It works and sometimes doesn’t

yeah, I see it work about 0% now…thankfully she’s still a great healer, but i’d like to know what’s going on with hook shot though.

You know the drill! Submit a video of it happening to support through official channels. That’s the only way we can gather the data we need to investigate. Verbal accounts miss details that you might think are unimportant, but go a long way towards solving any issues.

1 Like

yes sir I do know the drill, but I wasn’t sure if it was a bug or an adjustment in the skill that allowed for resistance. Didn’t want to report a non-issue.

Also, I have no idea how to take a video of it as i’m playing on my phone. iPhone. If I have that capability then i’d need some “iPhone for Dummies” instructions on how to video a match.

Issues reported to support get ignored. Tickets get closed without resolution and there is no way to re open them. I reported a bug with daily gold mission about 20 times and it is still hit and miss regarding if it works or not. This is why people resort t9 reporting problems in public here…

1 Like

That’s outright false, and I take personal offense to that statement. Our response time is under a few hours, currently. Support can’t resolve all issues instantly, but anything that is an actual issue is logged, and the devs begin work fixing it. That might take time, too.

You did not report any issue 20 times. Don’t conflate “I didn’t like the response I got” with no response. You’re spreading misinformation.


My only issue with this whole thread is you’re asking us to record it and send it in. Not everyone records all their matches also I still can’t even send pictures to support. The add option is still gone

You don’t have to record it or send it in if you don’t want to. We’ve tried reproducing the issue on our end, and it functions correctly. How else can we see what you’re seeing? There are details in video, as I said, that you might not find important, and will fail to report, that are actually critical.

We’ve also explained before that the iOS13 update has caused Helpshift, our support software provider, to be unable to accept image attachments. I’m sure support has told you that, and what to do as a workaround for it, if you’ve contacted them.

As there’s nothing being added to the discussion anymore, I’ll be shutting this down. If you would like to help us narrow down the issue you’re seeing, you know what to do. It’s up to you if you want to help us help you. There’s probably something being missed somewhere that we’re only going to see by knowing the exact, precise circumstances surrounding the issue. We can’t get that if the focus is on blaming us for asking for information that we require in order to assist.